主力净买额指标源代码?

时间:2021-04-08 00:03:02 作者:查股票网

A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE

成交额:=V*C/100,NODRAW;

A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);

A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);

A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);

A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);

A6:=((A2+A3)+A4)+A5;

A7:=IF((ISLASTBAR),((100*A2)/A6),0);

A8:=IF((ISLASTBAR),((100*A3)/A6),0);

A9:=IF((ISLASTBAR),((100*A4)/A6),0);

A10:=IF((ISLASTBAR),((100*A5)/A6),0);

机构买:(A2),LINETHICK6,COLORRED;

机构卖:(A3),LINETHICK6,COLORGREEN;

机构进出:机构买-机构卖,NODRAW;

散户买:(A4),COLOR5555FF;

散户卖:(A5),COLOR55FF 55;

散户进出:散户买-散户卖,NODRAW;

强势:((100*A2)/A6>50);

STICKLINE(强势,机构买*1.02,机构买*1.1,1,0),COLORYELLOW;

拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;

STICKLINE(拉升,机构买*1.1,机构买*1.2,1,0),COLORRED;

DRAWTEXT(ISLASTBAR=1,机构买*0.95,''),LINETHICK2,COLORRED;

DRAWTEXT(ISLASTBAR=1,机构卖*0.95,''),LINETHICK2,COLORFFFF55;

Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);

Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));

DRAWICON(CROSS((C/Q2),1.03),机构买,5);

XG:C/Q2;

DD1:=1;

AAA1:=STRCAT(STRCAT('机构买入',CON2STR((100*A2)/A6,0)),'%');

AAA2:=STRCAT(STRCAT('机构卖出',CON2STR((100*A3)/A6,0)),'%');

AAA0:=STRCAT(STRCAT('机构总买入',CON2STR((100*(A2-A3))/A6,0)),'%');

AAA3:=STRCAT(STRCAT('散户买入',CON2STR((100*A4)/A6,0)),'%');

AAA4:=STRCAT(STRCAT('散户卖出',CON2STR((100*A5)/A6,0)),'%');

AAA5:=STRCAT(STRCAT('散户总买入',CON2STR((100*(A4-A5))/A6,0)),'%');

DRAWTEXT_FIX(DD1=1,0.001,0.05,0,AAA1),COLORRED;

DRAWTEXT_FIX(DD1=1,0.001,0.15,0,AAA2),COLORGREEN;

DRAWTEXT_FIX(DD1=1,0.001,0.25,0,AAA3),COLORRED;

DRAWTEXT_FIX(DD1=1,0.001,0.35,0,AAA4),COLORGREEN;

DRAWTEXT_FIX(DD1=1,0.001,0.45,0,AAA0),LINETHICK5,COLORCYAN;

DRAWTEXT_FIX(DD1=1,0.001,0.55,0,AAA5),LINETHICK5,COLORCYAN;

主力净买额:=(机构进出+散户进出)/成交额,NODRAW;

AAA6:=STRCAT(STRCAT('主力净买额',CON2STR(主力净买额,0)),'%');

DRAWTEXT_FIX(DD1=1,0.001,0.65,0,AAA6),COLORMAGENTA;

声明:本文内容由查股票网用户自发贡献上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至查股票网,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。

相关推荐

怎样看K线图?上升三角形的形态分析有哪些?

在股票指数的K线图中,在每日分时动态走势图中,我们常可看到因多空双方激烈搏斗而形成的直角三角形图形。这种图形是由一条水平线与另一条斜线相交构成的。

    无相关信息